summary refs log tree commit diff
path: root/hosts/vps/hardware-configuration.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-07-30 13:19:39 +0300
committertzlil <tzlils@protonmail.com>2023-07-30 13:19:39 +0300
commitf72f22b250ecf22657ffc9e6082086377031ea8a (patch)
treece0f397e0933118b64bc58fab5463968d27fd0df /hosts/vps/hardware-configuration.nix
parent22743d455ebb1f44f07b429a2b82045ca5b1d3ac (diff)
clean up a bit
Diffstat (limited to 'hosts/vps/hardware-configuration.nix')
-rw-r--r--hosts/vps/hardware-configuration.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/hosts/vps/hardware-configuration.nix b/hosts/vps/hardware-configuration.nix
new file mode 100644
index 0000000..2d9a5fa
--- /dev/null
+++ b/hosts/vps/hardware-configuration.nix
@@ -0,0 +1,36 @@
+{
+  inputs,
+  pkgs,
+  lib,
+  config,
+  ...
+}: {
+     fileSystems = {
+      "/" = {
+        device = "none";
+        fsType = "tmpfs";
+        options = ["noexec" "defaults" "size=2G" "mode=755"];
+      };
+      "/nix" = {
+        device = "/dev/disk/by-uuid/e4c4735d-bfdd-477f-bc43-d07510cb6a9a";
+        fsType = "btrfs";
+      };
+      "/boot" = {
+        device = "/dev/disk/by-uuid/7ea63707-099d-4c21-90eb-a51bfa6d8ba5";
+        fsType = "ext4";
+      };
+    };
+
+    swapDevices = [{device = "/dev/disk/by-uuid/00eb2d2e-4d7c-4e95-804d-e9ecb22679d4";}];
+
+    zramSwap = {
+      enable = true;
+      algorithm = "zstd";
+    };
+
+
+    nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+    hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+    virtualisation.hypervGuest.enable = true;
+
+}