summary refs log tree commit diff
path: root/hosts/vps/default.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-07-30 13:19:39 +0300
committertzlil <tzlils@protonmail.com>2023-07-30 13:19:39 +0300
commitf72f22b250ecf22657ffc9e6082086377031ea8a (patch)
treece0f397e0933118b64bc58fab5463968d27fd0df /hosts/vps/default.nix
parent22743d455ebb1f44f07b429a2b82045ca5b1d3ac (diff)
clean up a bit
Diffstat (limited to 'hosts/vps/default.nix')
-rw-r--r--hosts/vps/default.nix50
1 files changed, 6 insertions, 44 deletions
diff --git a/hosts/vps/default.nix b/hosts/vps/default.nix
index 3597c5c..4741374 100644
--- a/hosts/vps/default.nix
+++ b/hosts/vps/default.nix
@@ -5,29 +5,17 @@
   ...
 }: {
   imports = [
-    ../../profiles/core.nix
-    ../../profiles/user.nix
-    ../../profiles/ssh.nix
+    ./hardware-configuration.nix
     ../../mixins/tailscale.nix
     ../../mixins/cli.nix
-    ./website.nix
-    ./git.nix
-    ./hydrus.nix
-    ./matrix.nix
-    ./maloja.nix
+    ./services/website.nix
+    ./services/git.nix
+    ./services/hydrus.nix
+    ./services/matrix.nix
+    ./services/maloja.nix
   ];
 
   config = {
-    _module.args.nixinate = {
-      host = "vps";
-      sshUser = "tzlil";
-      buildOn = "remote"; # valid args are "local" or "remote"
-      substituteOnTarget = true; # if buildOn is "local" then it will substitute on the target, "-s"
-      hermetic = false;
-    };
-
-    networking.hostName = "vps";
-
     boot = {
       kernelPackages = lib.mkDefault pkgs.linuxPackages_latest;
       loader.grub.device = "/dev/vda";
@@ -41,34 +29,8 @@
 
     networking.interfaces.ens3.useDHCP = lib.mkDefault true;
 
-    nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
-    hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
-    virtualisation.hypervGuest.enable = true;
-
     time.timeZone = lib.mkDefault "Frankfurt";
 
-    fileSystems = {
-      "/" = {
-        device = "none";
-        fsType = "tmpfs";
-        options = ["noexec" "defaults" "size=2G" "mode=755"];
-      };
-      "/nix" = {
-        device = "/dev/disk/by-uuid/e4c4735d-bfdd-477f-bc43-d07510cb6a9a";
-        fsType = "btrfs";
-      };
-      "/boot" = {
-        device = "/dev/disk/by-uuid/7ea63707-099d-4c21-90eb-a51bfa6d8ba5";
-        fsType = "ext4";
-      };
-    };
-
-    swapDevices = [{device = "/dev/disk/by-uuid/00eb2d2e-4d7c-4e95-804d-e9ecb22679d4";}];
-
-    zramSwap = {
-      enable = true;
-      algorithm = "zstd";
-    };
 
     networking.networkmanager.enable = lib.mkForce false;