summary refs log tree commit diff
path: root/hosts/vm/cfg.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-01-21 17:34:49 +0200
committertzlil <tzlils@protonmail.com>2023-01-21 17:34:49 +0200
commitd9317de584c66b068a336889aa9adc3ac3837e5e (patch)
treef9418f271c8e9bdc2cc6075de471bc4b7049f965 /hosts/vm/cfg.nix
parent5aa3d1eb375f7d67b717f0306752bd974fce1fbc (diff)
change deploy-rs to nixinate, change user to use passwordFile, add password age secret, remove NetworkManager-wait-online.service
Diffstat (limited to 'hosts/vm/cfg.nix')
-rw-r--r--hosts/vm/cfg.nix16
1 files changed, 11 insertions, 5 deletions
diff --git a/hosts/vm/cfg.nix b/hosts/vm/cfg.nix
index 8efee3b..3b5ace8 100644
--- a/hosts/vm/cfg.nix
+++ b/hosts/vm/cfg.nix
@@ -11,7 +11,18 @@
   ];
 
   config = {
+    _module.args.nixinate = {
+      host = "100.109.155.123";
+      sshUser = "tzlil";
+      buildOn = "remote"; # valid args are "local" or "remote"
+      substituteOnTarget = true; # if buildOn is "local" then it will substitute on the target, "-s"
+      hermetic = false;
+    };
     networking.hostName = "vm";
+
+    # dont do this
+    users.users.root.initialPassword = "hunter2";
+    
     boot.supportedFilesystems = ["9p"];
     boot = {
       initrd = {
@@ -53,11 +64,6 @@
       "/boot" = {
         device = "/dev/disk/by-partlabel/boot";
       };
-      "/flake" = {
-        fsType = "9p";
-        device = "host0";
-        options = ["_netdev"];
-      };
     };
 
     zramSwap = {