summary refs log tree commit diff
path: root/hosts/vm/cfg.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-02-16 16:40:26 +0200
committertzlil <tzlils@protonmail.com>2023-02-16 16:40:26 +0200
commitd4896b353eed0ab37cf8a2591fe1f5369c37883f (patch)
tree267fcc685ce9efa2db60e51c772ef58ccfe6d330 /hosts/vm/cfg.nix
parent566dc1e8f6e619f590f017a810a8a55d9a90a25c (diff)
stuff
Diffstat (limited to 'hosts/vm/cfg.nix')
-rw-r--r--hosts/vm/cfg.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/hosts/vm/cfg.nix b/hosts/vm/cfg.nix
index 4af1667..f9907e4 100644
--- a/hosts/vm/cfg.nix
+++ b/hosts/vm/cfg.nix
@@ -1,4 +1,4 @@
-{config, lib, pkgs, ...}: {
+{config, lib, pkgs, modulesPath, ...}: {
   imports = [
     ../../profiles/core.nix
     ../../profiles/user.nix
@@ -9,6 +9,7 @@
     ../../mixins/greet.nix
     # ../../mixins/hyprland.nix
     ../../mixins/sway.nix
+    (modulesPath + "/profiles/qemu-guest.nix")
   ];
 
   config = {
@@ -28,6 +29,7 @@
     boot = {
       initrd = {
         supportedFilesystems = ["btrfs"];
+        availableKernelModules = [ "ata_piix" "uhci_hcd" "floppy" "sd_mod" "sr_mod" ];
       };
       kernelPackages = lib.mkDefault pkgs.linuxPackages_latest;
       kernelParams = [
@@ -72,6 +74,6 @@
       algorithm = "zstd";
     };
 
-    # greeter.initialSession = "sh -c sway";
+    greeter.initialSession = "env WLR_RENDERER=pixman sh -c ${pkgs.sway}/bin/sway";
   };
 }
\ No newline at end of file