summary refs log tree commit diff
path: root/hosts/laptop/cfg.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-07-29 20:53:14 +0300
committertzlil <tzlils@protonmail.com>2023-07-29 20:53:14 +0300
commitfeefcfc89b00d4955dbb3314c20be035f3db206f (patch)
tree5099a13763dcfd274cae83af4dbac0bf4bef6cce /hosts/laptop/cfg.nix
parent11526bdd2bb3b4b445665aa671e4bc72021b8183 (diff)
disko for laptop, wip rewrite
Diffstat (limited to 'hosts/laptop/cfg.nix')
-rw-r--r--hosts/laptop/cfg.nix192
1 files changed, 0 insertions, 192 deletions
diff --git a/hosts/laptop/cfg.nix b/hosts/laptop/cfg.nix
deleted file mode 100644
index ab372c2..0000000
--- a/hosts/laptop/cfg.nix
+++ /dev/null
@@ -1,192 +0,0 @@
-{
-  config,
-  lib,
-  pkgs,
-  inputs,
-  ...
-}: {
-  imports = [
-    inputs.hardware.nixosModules.common-cpu-intel
-    inputs.hardware.nixosModules.common-gpu-intel
-    ../../profiles/core.nix
-    ../../profiles/user.nix
-    ../../profiles/ssh.nix
-    ../../profiles/graphical.nix
-    ../../mixins/tailscale.nix
-    ../../mixins/cli.nix
-    ../../mixins/greet.nix
-    # ../../mixins/hyprland.nix
-    ../../mixins/sway.nix
-    ../../mixins/pipewire.nix
-    ../../mixins/multimedia.nix
-    # ../../mixins/emacs
-    ../../mixins/syncthing.nix
-  ];
-
-  config = {
-    _module.args.nixinate = {
-      host = "100.121.226.3";
-      sshUser = "tzlil";
-      buildOn = "remote"; # valid args are "local" or "remote"
-      substituteOnTarget = true; # if buildOn is "local" then it will substitute on the target, "-s"
-      hermetic = false;
-    };
-    networking.hostName = "navi";
-
-    boot = {
-      initrd = {
-        supportedFilesystems = ["btrfs"];
-        availableKernelModules = ["xhci_pci" "ahci" "nvme" "usb_storage" "sd_mod" "usbhid" "snd_usb_audio"];
-      };
-      supportedFilesystems = ["ntfs"];
-      kernelModules = ["kvm-intel" "snd-seq" "snd-rawmidi" "bridge"];
-      kernelPackages = lib.mkDefault pkgs.linuxPackages_latest;
-      # extraModulePackages = [ config.boot.kernelPackages.rtl8821ce ];
-      loader = {
-        systemd-boot = {
-          enable = true;
-        };
-        efi = {
-          canTouchEfiVariables = true;
-          efiSysMountPoint = "/boot";
-        };
-      };
-    };
-
-    hardware.firmware = [pkgs.rtw88-firmware];
-
-    time.timeZone = lib.mkDefault "Israel";
-
-    fileSystems."/" = {
-      device = "none";
-      fsType = "tmpfs";
-      # hyprland doesnt compile with noexec root
-      options = ["defaults" "size=8G" "mode=755"];
-    };
-
-    fileSystems."/boot" = {
-      device = "/dev/disk/by-uuid/34CB-F158";
-      fsType = "vfat";
-    };
-
-    fileSystems."/nix" = {
-      device = "/dev/disk/by-uuid/8a8cc550-034e-4545-a958-564779f51061";
-      fsType = "btrfs";
-    };
-
-    zramSwap = {
-      enable = true;
-      algorithm = "zstd";
-    };
-
-    networking.interfaces.wlp1s0.useDHCP = lib.mkDefault true;
-
-    # # iwd networking stuffs
-    # networking.networkmanager.enable = lib.mkForce false;
-    # networking.wireless.iwd.enable = true;
-    # services.connman = {
-    #   enable = true;
-    #   wifi.backend = "iwd";
-    # };
-    # networking.wireless.dbusControlled = true;
-    # home-manager.users.tzlil.home.packages = [pkgs.cmst];
-    # networking.wireless.userControlled.enable = true;
-    # networking.wireless.enable = true;
-    # services.connman.enable = true;
-
-    services.tor = {
-      enable = true;
-      openFirewall = true;
-      client.enable = true;
-      torsocks.enable = true;
-    };
-    environment.persistence."/nix/persist".directories = [
-      "/etc/NetworkManager/system-connections"
-      {
-        directory = "/home/tzlil/.config/SchildiChat";
-        user = "tzlil";
-        group = "users";
-      }
-      {
-        directory = "/home/tzlil/.local/share/Terraria";
-        user = "tzlil";
-        group = "users";
-      }
-
-      {
-        directory = "/home/tzlil/.local/share/Steam";
-        user = "tzlil";
-        group = "users";
-      }
-      "/var/lib/docker"
-    ];
-
-    home-manager.users.tzlil = {
-      home.packages = [pkgs.schildichat-desktop-wayland pkgs.keepassxc];
-      programs.qutebrowser = {
-        enable = true;
-        settings.colors.webpage.darkmode.enabled = true;
-      };
-    };
-
-    programs.steam.enable = true;
-
-    programs.firejail.wrappedBinaries = {
-      mullvad-browser = {
-        executable = lib.getExe pkgs.mullvad-browser;
-        extraArgs = [
-          "--env=MOZ_ENABLE_WAYLAND=1"
-          "--env=GTK_THEME=Adwaita:dark"
-        ];
-        # profile = "${pkgs.firejail}/etc/firejail/firefox.profile";
-      };
-    };
-
-    nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
-    powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
-    hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
-
-    nixpkgs.config.allowUnfree = true;
-    hardware.enableAllFirmware = true;
-
-    # greeter.initialSession = "${pkgs.fish}/bin/fish";
-
-    hardware.opengl = {
-      enable = true;
-      extraPackages = with pkgs; [rocm-opencl-icd rocm-opencl-runtime];
-      driSupport = true;
-      driSupport32Bit = true;
-    };
-
-    networking.firewall.allowedTCPPorts = [25565];
-
-    services = {
-      power-profiles-daemon.enable = true;
-      thermald.enable = true;
-      tlp = {
-        settings = {
-          CPU_BOOST_ON_AC = 1;
-          CPU_BOOST_ON_BAT = 0;
-          CPU_SCALING_GOVERNOR_ON_AC = "performance";
-          CPU_SCALING_GOVERNOR_ON_BAT = "powersave";
-        };
-      };
-      acpid.enable = true;
-    };
-
-    hardware.bluetooth.enable = true;
-    services.blueman.enable = true;
-
-    # dont know if i like this
-    nix.settings.trusted-public-keys = [
-      "hydra.iohk.io:f/Ea+s+dFdN+3Y/G+FDgSq+a5NEWhJGzdjvKNGv0/EQ="
-    ];
-    nix.settings.substituters = [
-      "https://cache.iog.io"
-    ];
-
-    virtualisation.docker.enable = true;
-    virtualisation.docker.storageDriver = "btrfs";
-    users.users.tzlil.extraGroups = ["docker"];
-  };
-}