summary refs log tree commit diff
path: root/hosts/laptop/cfg.nix
diff options
context:
space:
mode:
authortzlil <tzlils@protonmail.com>2023-07-13 15:33:47 +0300
committertzlil <tzlils@protonmail.com>2023-07-13 15:33:47 +0300
commit36b0692fb7dca966aba42fa093aab84913432ba8 (patch)
treebc9b3095ed2197f9a2ce89f855bc065916ff457b /hosts/laptop/cfg.nix
parenta21c56fba470e6dc3f3da0948fb914fb485556bf (diff)
add nix shell function, format, add networkx to python repl
Diffstat (limited to 'hosts/laptop/cfg.nix')
-rw-r--r--hosts/laptop/cfg.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/hosts/laptop/cfg.nix b/hosts/laptop/cfg.nix
index 35dbde7..4e2f843 100644
--- a/hosts/laptop/cfg.nix
+++ b/hosts/laptop/cfg.nix
@@ -94,6 +94,12 @@
     # networking.wireless.enable = true;
     # services.connman.enable = true;
 
+    services.tor = {
+      enable = true;
+      openFirewall = true;
+      client.enable = true;
+      torsocks.enable = true;
+    };
     environment.persistence."/nix/persist".directories = [
       "/etc/NetworkManager/system-connections"
       {
@@ -112,7 +118,7 @@
     home-manager.users.tzlil = {
       home.packages = [pkgs.schildichat-desktop-wayland pkgs.keepassxc];
       programs.qutebrowser = {
-	 enable = true;
+        enable = true;
         settings.colors.webpage.darkmode.enabled = true;
       };
     };
@@ -175,6 +181,6 @@
 
     virtualisation.docker.enable = true;
     virtualisation.docker.storageDriver = "btrfs";
-    users.users.tzlil.extraGroups = [ "docker" ];
+    users.users.tzlil.extraGroups = ["docker"];
   };
 }